RWW: Gun Maniac Pratt: Founders Would Want Everyone To Carry An M-16 ‘At A Minimum’ – AUDIO

5

Larry Pratt, the executive director emeritus of Gun Owners of America, insisted over the weekend that the founding fathers would have wanted every military-age man in the U.S. to carry an M-16 rifle “at a minimum.”

Pratt invited Don Brockett, the author of a book called “The Tyrannical Rule of the U.S. Supreme Court,” to his “Gun Owners News Hour” program on Saturday. Brocket argued that the Second Amendment exists to allow states to defend themselves against invasion, which he said could mean that people should be allowed to have “equal weaponry” to an “invading army,” such as rocket-propelled grenades.

“In Article 1, Section 10, where the state can’t engage in war unless it’s invaded, well how can it defend itself if it’s being invaded if the people don’t have any Second Amendment right to arms?” Brockett asked. “And I maintain in the book, even though some may think this is going too far, that you’re entitled to the same measure of weapons as the weapons that might be used against you. So does that mean everybody can have an RPG in their home? I don’t know. I think we need to discuss it, because how could you stop the invading army unless you have the equal weaponry? Or if you want to provide it by your national guard, which can be distributed to individual citizens when that need comes about.”

Pratt responded that the Militia Acts of 1792 “seemed to provide for making sure all militia-age men had to have military firearms. Now, I suppose in today’s context, at a minimum that would be the machine gun battle rifle, the M-16, or whatever its modern, even more modern equivalent is, that every American soldier would be carrying. That would seem to me, if those were laws consistent with the Second Amendment, then that would be kind of what the founders and their successors had in mind.”

Brockett then brought up the possibility of a state needing to be prepared to repel “an invading army,” including perhaps “the federal government invading the state.”

Reblogged 1 year ago from www.rightwingwatch.org
Share.

Comments

Google no longer supports Google Images API and this plugin can't work.

You can try to use other plugins with the same feature:
WP Picasa Box - http://codecanyon.net/item/wp-picasa-box/16099962
WP Pixabay Search And Insert - http://wpclever.net/downloads/wordpress-pixabay-search-and-insert